Selected item issue

Currently in public beta: Windows Phone version

Moderators: Stefan2, white, sheep, Hacker

Post Reply
wc2005
Junior Member
Junior Member
Posts: 6
Joined: 2016-03-06, 15:17 UTC

Selected item issue

Post by *wc2005 » 2016-03-06, 15:37 UTC

I'm using Total Commander 1.5, when using "Select range of files" to select files, the number indicates the selected items (on the upper right corner) gets incorrect. Please have a look at that.

Thanks!

I'm on Lumia 640 XL, Windows phone 8.1 update 2

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36554
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2016-03-07, 10:02 UTC

I will check it, thanks for your report.
Author of Total Commander
http://www.ghisler.com

User avatar
ts4242
Power Member
Power Member
Posts: 1987
Joined: 2004-02-02, 20:08 UTC
Contact:

Post by *ts4242 » 2016-03-07, 20:25 UTC

Cannot confirm!

TC 1.5, WP 8.1 update 2

Author of Ultra TC Editors
Please support me

wc2005
Junior Member
Junior Member
Posts: 6
Joined: 2016-03-06, 15:17 UTC

Post by *wc2005 » 2016-03-08, 11:23 UTC

I should give you more details so that you can reproduce the issue, in case this is a TC bug, please try this:
Select 1 file by tapping on the left half of that file icon
Then long tap on that file icon, choose 'Select files', tap on the last icon in the range
Now i see the selected item number does not update itself. If i select/unselect files one by one, it now updates itself. If i long tap on selected items, choose "remove selection from files" to unselect selected files, that number does not update itself again
It seems selected item number does not update itself when using "Select range of files".

I hope i am clear enough for you to understand. Thanks!

phantom
Senior Member
Senior Member
Posts: 487
Joined: 2003-11-21, 15:34 UTC

Post by *phantom » 2016-03-08, 12:39 UTC

I can confirm this issue. It seems to be a BUG.

TC 1.5 WP 8.1

User avatar
ts4242
Power Member
Power Member
Posts: 1987
Joined: 2004-02-02, 20:08 UTC
Contact:

Post by *ts4242 » 2016-03-09, 01:53 UTC

wc2005 wrote:I should give you more details so that you can reproduce the issue, in case this is a TC bug, please try this:
Select 1 file by tapping on the left half of that file icon
Then long tap on that file icon, choose 'Select files', tap on the last icon in the range
Confirmed!

Sorry, first time I was using select files dialog.

Author of Ultra TC Editors
Please support me

wc2005
Junior Member
Junior Member
Posts: 6
Joined: 2016-03-06, 15:17 UTC

Post by *wc2005 » 2016-03-09, 08:21 UTC

I've noticed the issue also happens to the found items when using search function. Please check it.

Thanks!

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36554
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2016-03-10, 09:51 UTC

Thanks, I could reproduce both problems. It's only a display problem, the files are counted correctly: Just select one more/less, and the numbers will be correct. I will fix it.
Author of Total Commander
http://www.ghisler.com

wc2005
Junior Member
Junior Member
Posts: 6
Joined: 2016-03-06, 15:17 UTC

Post by *wc2005 » 2016-03-11, 12:26 UTC

Please try this:
Select files using check box mode
Now sort the lister, i see the lister is sorted, the checked items are still checked, the selected item number is not updated but when selecting more items, the selected item number gets incorrect.

I think this is a display problem again. Please check it, thanks.

phantom
Senior Member
Senior Member
Posts: 487
Joined: 2003-11-21, 15:34 UTC

Post by *phantom » 2016-03-13, 11:59 UTC

Sorting cause this kind of problem. You get the same problems if you use "Select". And "Remove Selection" doesn't work correctly also anymore.

User avatar
ts4242
Power Member
Power Member
Posts: 1987
Joined: 2004-02-02, 20:08 UTC
Contact:

Post by *ts4242 » 2016-05-12, 07:12 UTC

Fixed in TC 1.6

Author of Ultra TC Editors
Please support me

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36554
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2016-05-12, 09:56 UTC

Thanks for checking, also the other two problems!
Author of Total Commander
http://www.ghisler.com

Post Reply