This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

File count doubled in progress window

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC9.0x bug reports (English) Printable version
View previous topic :: View next topic  
Author Message
Pantalaimon
Junior Member
Junior Member


Joined: 17 Aug 2017
Posts: 4

PostPosted: Thu Aug 17, 2017 3:03 am    Post subject: File count doubled in progress window Reply with quote

The file count displayed in the progress window seems to be double the actual file count.

To illustrate: [EDIT] I wanted to attach an image, but since this is my first post, it won't let me Smile

[EDIT2] honey-pot.nl/temp/tc90a_file_count_bug.png



Moderation:

http://honey-pot.nl/temp/tc90a_file_count_bug.png


 


Last edited by Pantalaimon on Thu Aug 17, 2017 10:57 am; edited 1 time in total
Back to top
View user's profile Send private message
Dalai
Power Member
Power Member


Joined: 28 Jan 2005
Posts: 6050
Location: Meiningen (Südthüringen)

PostPosted: Thu Aug 17, 2017 8:14 am    Post subject: Reply with quote

Post the link without any http and www prefixes.

Regards
Dalai
_________________
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups
Back to top
View user's profile Send private message Send e-mail
Pantalaimon
Junior Member
Junior Member


Joined: 17 Aug 2017
Posts: 4

PostPosted: Thu Aug 17, 2017 10:58 am    Post subject: Reply with quote

OP updated with 'link'
Back to top
View user's profile Send private message
Dalai
Power Member
Power Member


Joined: 28 Jan 2005
Posts: 6050
Location: Meiningen (Südthüringen)

PostPosted: Thu Aug 17, 2017 1:14 pm    Post subject: Reply with quote

Did you count the files before deleting them using Ctrl+L, including all of the subdirectories? The number in the status bar is only the number in the current directory. So unless you have a flat structure, i.e. all files in the current directory, the two numbers may not be the same.

Regards
Dalai
_________________
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups
Back to top
View user's profile Send private message Send e-mail
Pantalaimon
Junior Member
Junior Member


Joined: 17 Aug 2017
Posts: 4

PostPosted: Thu Aug 17, 2017 3:11 pm    Post subject: Reply with quote

Dalai wrote:
Did you count the files before deleting them using Ctrl+L, including all of the subdirectories? The number in the status bar is only the number in the current directory. So unless you have a flat structure, i.e. all files in the current directory, the two numbers may not be the same.

Regards
Dalai


There were no subdirectories present. I've tested this on more than one occasion with different number of files, and every time it reports double the number of files as shown in the screenshot.

I'll see if I can do some more tests tomorrow involving subdirectories and how the count relates to those cases.
Back to top
View user's profile Send private message
Pantalaimon
Junior Member
Junior Member


Joined: 17 Aug 2017
Posts: 4

PostPosted: Fri Aug 18, 2017 1:35 am    Post subject: Reply with quote

I've done some more tests on this. I created 2 scenarios. From each I selected all files and directories and performed a copy, move and delete

Scenario 1:
./ (1000 files, 2 directories)
./subdir1/ (100 files)
./subdir2/ (50 files)

File count reported:
COPY/MOVE: 1152
- 1150 files, 2 directories, seems OK

DELETE: 2154
- Apparently double the count of files+directories in the current directory = 2004
- Added with the correct count of files in both subdirectories = 150


Scenario 2:
./ (1000 files, 1 directory)
./subdir1/ (100 files, 1 directory)
./subdir1/subdir2/ (50 files)

File count reported:
COPY/MOVE: 1152
- 1150 files, 2 directories, seems OK

DELETE: 2153
- Apparently double the count of files+directories in the current directory = 2002
- Added with the correct count of files+directories in subdir1 = 151


Copy and move are reporting the correct number of items if we add both number of files and directories together.
Deleting files is reporting double the amount of files and directories in the current directory, and the correct amount of files and directories in any subdirectory.
Back to top
View user's profile Send private message
Dalai
Power Member
Power Member


Joined: 28 Jan 2005
Posts: 6050
Location: Meiningen (Südthüringen)

PostPosted: Fri Aug 18, 2017 7:56 am    Post subject: Reply with quote

Can you reproduce this with a clean wincmd.ini? Start TC like this:
Code:
totalcmd64.exe /i="%temp%\fresh.ini"


I tried to reproduce this in TC 8.52a and 9.0a, both 32 and 64 bit on Win7, deleting to recycle bin and permanently, with varying numbers of (empty) files of up to 30k, with and without subdirs. No luck so far, TC always reports the correct number of files.

Regards
Dalai
_________________
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups
Back to top
View user's profile Send private message Send e-mail
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7802
Location: Valsted, Denmark

PostPosted: Fri Aug 18, 2017 11:44 am    Post subject: Reply with quote

2Pantalaimon
I have tried to reproduce this with TC 9.0a 32bit and 64bit under Windows 7 and Windows 10 on FAT32 and NTFS disks - deleting directly and deleting to recycle bin and deleting form Branch view and from normal Full view - and I cannot reproduce it.

Are your files possibly in a parent folder that is a hardlink or a symlink? What is the pattern of the file names if any. What are your settings for showing system/hidden files. What are your settings for ignored files - What is your Operating system and which version af TC are you using etc. etc.
_________________
#524
Danish Total Commander Translator
TC 9.20rc1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.91b3 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35761
Location: Switzerland

PostPosted: Mon Aug 21, 2017 7:24 am    Post subject: Reply with quote

I cannot reproduce it either - please provide more informarion, as requested by the other forum users. Thanks.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35761
Location: Switzerland

PostPosted: Mon Oct 02, 2017 3:47 am    Post subject: Reply with quote

So far I couldn't reproduce this problem - could anyone else reproduce it?
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC9.0x bug reports (English) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group