This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Select packer plugin through Internal Association fails

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs Printable version
View previous topic :: View next topic  
Author Message
Gral
Power Member
Power Member


Joined: 26 Jan 2005
Posts: 602

PostPosted: Mon Nov 20, 2017 7:22 am    Post subject: Select packer plugin through Internal Association fails Reply with quote

There is a bug when using packer plugin select through internal asssociations menu.
If i choose any plugin configured for file format for enter in to the file, then, until restart, TC opens this one particular file only with this one particular plugin, even if i select other plugin - choosing other packer plugin from popup menu simply doesn't work.
This is remembered separate for every single file.

I receive such a behaviour for executable files, CD\DVD images (ISO), and Disk Images (IMG)

This occurs only on newest version - TC 9.12RC4.
RC3 works correctly.

Sample - essesntial part of my internal associations configuration for executable files:

Filter3_7z (Packer Plugin)=**7z
Filter3_FAR (Packer Plugin)=**far
Filter3_Icon Library (Packer Plugin)=**icl
Filter3_Resource Extractor (Packer Plugin)=**pe
Filter3_WCRES (Packer Plugin)=**wcres
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35943
Location: Switzerland

PostPosted: Tue Nov 21, 2017 10:55 am    Post subject: Reply with quote

Confirmed, thanks! I fixed another problem when handling 7z unpacking with multiple passwords which caused a crash.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35943
Location: Switzerland

PostPosted: Tue Nov 21, 2017 3:56 pm    Post subject: Reply with quote

I found a solution and sent you a test version from my GMail address. Please test it and let me know if anything doesn't work as it should yet!
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Gral
Power Member
Power Member


Joined: 26 Jan 2005
Posts: 602

PostPosted: Wed Nov 22, 2017 2:21 am    Post subject: Reply with quote

I can confirm fix.
Tested 9.12RC4c on Windows XP SP3 x32
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35943
Location: Switzerland

PostPosted: Wed Nov 22, 2017 2:38 am    Post subject: Reply with quote

Great, thanks!
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group