Do not focus TC when a copy dialog pops up

Please report only one bug per message!

Moderators: Stefan2, white, sheep, Hacker

Post Reply
jozsi
Junior Member
Junior Member
Posts: 4
Joined: 2012-04-17, 22:57 UTC

Do not focus TC when a copy dialog pops up

Post by *jozsi » 2019-02-10, 22:03 UTC

There would be extremely useful a setting that prevents the popup dialogs during copy. Here is the thing: I'm typing hard in another application, while TC is synchronizing folders in the background. When the process meets a condition that should be asked by the user, a dialog pops up and TC is focused. Now, as I'm typing I will hit the appropriate underlined character that means pressing a button in the dialog box. A random character, whichever comes first when I'm typing. This way, I will select an option without realizing it.
Other applications do not bring themselves in the foreground, but start flashing the app button in the taskbar. A similar behavior would prevent very dangerous, unwanted options as deleting overwriting a file, etc.
This could be a checkable option in the copy dialog, before starting the effective copy operation.

User avatar
MVV
Power Member
Power Member
Posts: 8239
Joined: 2008-08-03, 12:51 UTC
Location: Russian Federation

Re: Do not focus TC when a copy dialog pops up

Post by *MVV » 2019-02-11, 08:07 UTC

Unfortunately all apps do that, strictly speaking, it is Windows who does that, applications just do their normal actions. It is quite dumb that Windows doesn't let user control focus stealing (BTW up to Windows XP there actually was a setting, but it was removed in newer Windows versions). It is not a TC fault, and any other app may steal your focus in the same way, you just was happy to get this only with TC.

But you can play with SkippedFileCopy parameter (read more in section 4.b of TOTALCMD.chm) of wincmd.ini and try to reduce delay during which TC still can show a confirmation, default is 5 seconds. And, I don't know if it affects synchronization...

Post Reply