LAN-Verbindung scheitert an SMBv2

German support forum

Moderators: sheep, Hacker, Stefan2, white

Post Reply
stau
New Member
New Member
Posts: 1
Joined: 2019-06-26, 10:47 UTC

LAN-Verbindung scheitert an SMBv2

Post by *stau » 2019-07-06, 17:53 UTC

Hallo,
Ich nutze zwei Android-Smartphones.
Auf dem ersten, einem Huawei, habe ich TC mit dem LAN-Plugin schon seit einiger Zeit im Einsatz und die Verbindung zum Windows-Rechner als Server funktioniert wunderbar.
TC habe ich auf dem zweiten Gerät, einem Sony M4 Aqua, erst heute inkl. LAN-Plugin eingerichtet.
Dort erhalte ich bei gleichen Einstellungen den Verbindungsfehler "smbv2 ... Connect Host is unresolved.

Meine Einstellungen sind:
SMB2 aktiviert, ältere NAS-Kompatibilität deaktiviert und alte Methode zur Namensauflösung deaktiviert.
Ich habe auch schon versucht die Vebindung "alte Methode zur Namensauflösung" zu aktivieren. Auch damit scheitere ich.

Mich verwundert ganz besonders, dass die LAN-Verbindung bei einem Gerät läuft und beim anderen scheitert.
Ich habe von solchen Verbindungsproblemen gelesen. Diese sollen jedoch schon längerer Zeit gelöst worden sein.
Hat jemand eine Idee, woran das liegen kann?

User avatar
Dalai
Power Member
Power Member
Posts: 6742
Joined: 2005-01-28, 22:17 UTC
Location: Meiningen (Südthüringen)

Re: LAN-Verbindung scheitert an SMBv2

Post by *Dalai » 2019-07-06, 18:31 UTC

Welche Windows-Version ist auf dem PC im Einsatz?

Grüße
Dalai
#101164 Personal licence
Ryzen 5 2600, 16 GiB RAM, ASUS Prime X370-A, Win7 x64

Plugins: Services2, Startups

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38074
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN-Verbindung scheitert an SMBv2

Post by *ghisler(Author) » 2019-07-08, 19:25 UTC

Host is unresolved
Das bedeutet, dass der angegebene Servername nicht gefunden wurde. Bitte geben Sie im Serverfeld NUR den PC-Namen an, oder alternativ die IP-Adresse des PCs. Diese können Sie herausfinden, indem Sie auf dem PC cmd.exe starten und folgenden Befehl eingeben:
ipconfig

Wenn es mehrere Abschnitte mit Adressen gibt, suchen Sie nach einem wo "Standardgateway" einen Wert hat. Dort dann den Wert hinter
IPv4-Adresse nehmen.
Author of Total Commander
http://www.ghisler.com

hgdorn
Junior Member
Junior Member
Posts: 18
Joined: 2009-04-22, 13:11 UTC
Location: Germany

Re: LAN-Verbindung scheitert an SMBv2

Post by *hgdorn » 2019-07-14, 19:18 UTC

Ich habe gerade ebenfalls ein merkwürdiges Problem mit SMB2. Auf meinen Linux-Rechnern hatte ich aus Sicherheitsgründen SMb1 deaktiviert bzw. Samba per smb.conf auf "server|client|... min protocol = SMB2" konfiguriert. Eben stolperte ich darüber, dass das LAN Plugin nicht mehr zu meinen Linux-Rechnern connecten konnte. Zurück auf SMB1 ging es, mit SMB2 nicht. (siehe "LAN plugin broken?")

Wenn ich eine Server-Verbindung auf "SMB2" umstelle, gelingt die Verbindung nicht. Auch nicht, wenn ich "Alte Namensauflösung" oder "Ältere NAS-Kompatibilität" wähle. Ich denke, ich habe schon alle möglichen Kombinationen durch.

Ich habe auch direkt die IPv4-Adresse des Servers eingetragen, so dass eigentlich keine Probleme mit einer Namensauflösung auftreten können.

Android = 192.168.0.102
Linux = 192.168.0.119

Wenn ich mich nun per SMB2 verbinden will, kommt nach einiger Zeit die Fehlermeldung
SMB2 connect: failed to connect to
tux.fritz.box/192.168.0.114 (port 445)
from /192.168.0.102 (port 50215) after 5000 ms:
///LAN/192.168.0.119/foobar

.114? Häh? Amkopfkratz.

Habe auf meinem Linux-Rechner einen "nslookup 192.168.0.119" gemacht und erhalte tatsächlich von der Fritzbox für eine IPv4-Adresse eine andere IPv4-Adresse zurück. Ähm, ja, bin verwirrt. Im Netz gibt es derzeit kein Gerät, dem die .114 zugewiesen wurde.

Frage: Warum macht das LAN Plugin trotz direkter Angabe einer IPv4-Adresse dennoch eine Namensauflösung?

Jetzt mal unabhängig davon, dass meine Fritzbox da - warum auch immer, das ist mir momentan zu hoch - da für die .119 eine .114 zurückliefert.

Edit: Vermutung: Der DHCP-Server der Fritzbox hat meinem Linux-Rechner (tux) für LAN (114) und WLAN (119) zwei IP-Adressen vergeben. Derzeit ist der Rechner nur per WLAN verbunden (119). Wenn ich nun mit dem LAN-Plugin direkt auf die 192.168.0.119 verbinde, löst das LAN-Plugin dennoch den Namen auf, erhält neben dem Namen auch zwei IP-Adressen und nutzt für die Verbindung die erste (114), und die ist derzeit nicht in Benutzung. Ich weiß jetzt nicht, ob das wirklich so passiert und ob hier und wenn ja welche beteiligte Komponente etwas falsch macht. :?:
#9260

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38074
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN-Verbindung scheitert an SMBv2

Post by *ghisler(Author) » 2019-07-15, 14:24 UTC

Sehr seltsam, das LAN-Plugin macht bei Angabe einer IPv4-Adresse keine Namensauflösung.
Author of Total Commander
http://www.ghisler.com

hgdorn
Junior Member
Junior Member
Posts: 18
Joined: 2009-04-22, 13:11 UTC
Location: Germany

Re: LAN-Verbindung scheitert an SMBv2

Post by *hgdorn » 2019-07-15, 14:55 UTC

Ja, in der Tat seltsam. Welchen Grund könnte es geben, dass $WERAUCHIMMER auf die .114 zugreifen will und das LAN-Plugin dann Fehlermeldung mit der .114 auswirft? Das mit der Namensauflösung war nur eine Spekulation, weil das Resulat so schön einleuchtend war. Vielleicht weiß das jemand?
#9260

CoolWater
Power Member
Power Member
Posts: 674
Joined: 2003-03-27, 16:33 UTC

Re: LAN-Verbindung scheitert an SMBv2

Post by *CoolWater » 2019-07-15, 16:32 UTC

Ich würde mal in der FritzBox die entsprechenden Geräte aus der Heimnetzübersicht löschen.

Ist sichergestellt, dass es sonst keinen DHCP-Server im Netzwerk gibt?

hgdorn
Junior Member
Junior Member
Posts: 18
Joined: 2009-04-22, 13:11 UTC
Location: Germany

Re: LAN-Verbindung scheitert an SMBv2

Post by *hgdorn » 2019-07-15, 18:12 UTC

CoolWater wrote:
2019-07-15, 16:32 UTC
Ich würde mal in der FritzBox die entsprechenden Geräte aus der Heimnetzübersicht löschen.
Das hat geholfen. Vermutlich jedenfalls, bis ich den Rechner mal wieder per Kabel mit der Fritzbox verbinde.
CoolWater wrote:
2019-07-15, 16:32 UTC
Ist sichergestellt, dass es sonst keinen DHCP-Server im Netzwerk gibt?
Ja.
#9260

CoolWater
Power Member
Power Member
Posts: 674
Joined: 2003-03-27, 16:33 UTC

Re: LAN-Verbindung scheitert an SMBv2

Post by *CoolWater » 2019-07-16, 09:55 UTC

Das ist ja schon kurios.. Ich hätte jetzt vermutet, dass die FB die einzelnen Geräte per MAC-Adresse identifiziert und nicht anhand des Namens.. Ggf. lohnt sich ja eine Email an den AVM-Support mit der Problemstellung.

Gruß
CoolWater

Post Reply