E.g.:
Code: Select all
someplugin.RawContents matches "abc"
someplugin.DirContains matches "descript.ion"
someplugin.DirContains matches "..\desktop.ini"
someplugin.ImageSize matches "small or medium"
Moderators: Hacker, petermad, Stefan2, white
Code: Select all
someplugin.RawContents matches "abc"
someplugin.DirContains matches "descript.ion"
someplugin.DirContains matches "..\desktop.ini"
someplugin.ImageSize matches "small or medium"
YesSo you suggest to add user-defined operators instead of special fields?
Same as nowWhat will field name do in your case?
Why do you think I do? Of course a field is a field and a value is a value. The connection is that the field retrieves the value. Nothing should be changed about this. This would be confusing.And I don't understand why would plugin field and value be the same - field describes an action and value is a parameter for that action...
Try to think about ther use case first and then we can talk about how it could work.I thought about an operator that can be used for all content fields, and ContentGetSupportedFieldFlags function could export a flag for fields supporting this operator, in such case parameter could define e.g. some kind of custom format string (for fields that export values other than boolean). I don't know though will it be useful or not.
Please provide an example where field name and operator name both have sense. In my mind two user-defined names are redundant so they could be merged into one field name so it would be enough one specific operator.Same as now
In my case value would be used as a parameter for the field, and result would be boolean, while in standard case value is compared with field result by TC.Why do you think I do? Of course a field is a field and a value is a value. The connection is that the field retrieves the value. Nothing should be changed about this. This would be confusing.
Code: Select all
someplugin.DirContains matches "DTAR_08E86330_4835_4B5C_9E5A_61F37AE1A077_DTAR"