tcmdwince und WinCe Core 5.0

Support for PocketPC and WinCE version

Moderators: Stefan2, white, sheep, Hacker

User avatar
Snooze
Member
Member
Posts: 173
Joined: 2005-12-08, 16:48 UTC
Location: im Vest

tcmdwince und WinCe Core 5.0

Post by *Snooze » 2007-06-07, 21:08 UTC

läuft der TC nicht unter Windows CE Core 5.0 (ARM 920 T)?

Fehlermeldung ist:
this is not a WinCe application

mir scheint das 'Core' ein abgespecktes System ist
kann man es irgendwie updaten?

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36544
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-06-08, 14:49 UTC

Das scheint daran zu liegen, dass nicht alle von Total Commander Pocket benötigten Funktionen vorhanden sind.

Leider konnte ich nirgends finden, welche Funktionen genau bei Windows CE Core fehlen, sonst könnte ich andere Lösungen für diese Funktionen suchen.

English: It seems that Windows CE Core is missing some functions available in Windows Mobile. Unfortunately I couldn't find any info about what functions are missing.
Author of Total Commander
http://www.ghisler.com

amai2
Junior Member
Junior Member
Posts: 5
Joined: 2007-06-09, 17:47 UTC

Post by *amai2 » 2007-06-09, 17:55 UTC

On MSDN there's a word document describing the differences in terms of functionality (look for "Run-time Licensing Model for Windows CE"). Note that it may not go down exactly to the level of missing Dlls or single APIs...

amai2

amai2
Junior Member
Junior Member
Posts: 5
Joined: 2007-06-09, 17:47 UTC

Post by *amai2 » 2007-06-09, 18:06 UTC

Ok, in addition to reading docs people with access to that HW may try to run peinfo on the executable in question. However I don't know if peinfo itself is going to work on that device :roll:

amai2

P.S. Since the board software prevents me from posting URLs I can't post it and so encourage people to use google instead...

User avatar
Snooze
Member
Member
Posts: 173
Joined: 2005-12-08, 16:48 UTC
Location: im Vest

Post by *Snooze » 2007-06-09, 19:30 UTC

i found, that only this .dll is necessary to run TC under WinCE

Code: Select all

commctrl.dll
coredll.dll
aygshell.dll
winsock.dll 
all this files are installed on my PNA, but TC never run

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36544
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-06-10, 09:47 UTC

The problem is that TC Pocket is using functions from these dlls which may be missing on your device.

I found a link to PEInfo via Google here:
http://www.yetanotherhomepage.com/j7xx/software/util/peinfo.html

Can you try it on your device, please?
Author of Total Commander
http://www.ghisler.com

User avatar
Snooze
Member
Member
Posts: 173
Joined: 2005-12-08, 16:48 UTC
Location: im Vest

Post by *Snooze » 2007-06-10, 11:16 UTC

OK

here the logfile (92,4 kb)LINK

amai2
Junior Member
Junior Member
Posts: 5
Joined: 2007-06-09, 17:47 UTC

Thumb mode...

Post by *amai2 » 2007-06-10, 16:36 UTC

Dll/API loading is fine.
There is no ARMV4T binary available??

amai2

User avatar
Snooze
Member
Member
Posts: 173
Joined: 2005-12-08, 16:48 UTC
Location: im Vest

Post by *Snooze » 2007-06-10, 16:42 UTC

ARMV4T???
it is necessary to run TC?

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36544
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-06-10, 19:30 UTC

The log file shows that all functions needed seem to be there.

2amai2
What do you mean with ARMV4T? The PocketPC 3.0 SDK only offers arm, mips and sh3 options, and the PPC 2002 SDK only ARM and X86. There are no variations of ARM to choose from.
Author of Total Commander
http://www.ghisler.com

amai2
Junior Member
Junior Member
Posts: 5
Joined: 2007-06-09, 17:47 UTC

Post by *amai2 » 2007-06-10, 20:59 UTC

@ghisler: PPC2003?? We're talking about a plain CE system, so I think one should use CE Standard SDK. Did you use a PPC SDK to create those builds? (hmm, usage of aygshell seems to indicate this...)
CE Standard SDKs 4.0/4.1/4.2 offer ARMV4T among others, I forget from the 3.x days, sorry.

Regards
amai2

P.S. I'm german, but thought discussions might also interest people w/o knowledge of german language 8)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36544
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-06-11, 08:29 UTC

For the PocketPC version, I'm using the PocketPC 3.0 SDK. Fir the WinCE version, I'm using the Windows CE 2.0 SDK.

What is this CE Standard SDKs 4.0? Does it work with Embedded VC++ 3.0? I have to use 3.0 to support CE2, CE3 and PocketPC 2002 devices.
Author of Total Commander
http://www.ghisler.com

albrecht33
Junior Member
Junior Member
Posts: 3
Joined: 2007-06-16, 14:21 UTC

Post by *albrecht33 » 2007-06-16, 14:42 UTC

Hallo,

auf irgendeiner koreanischen Seite habe ich eine alte Version von TotalCommander gefunden, die bei mir unter WinCE 5.0 (Loox N100)problemlos läuft (incl. eingebautem notepad etc).

Vorher hatte ich auch schon die hier liegenden Versionen 2.X probiert, bin aber ebenfalls an der hier beschriebenen Fehlermeldung gescheitert.

Zur Zeit werden ja PNAs mit WinCE in hohen Stückzahlen verkauft (Medion, Loox N100...)... und ein guter Dateimanager ist gerade auf diesen abgespecktenGeräten sehr hilfreich. Es scheinen ja daher auch eine Menge Leute Interesse zu haben...

Könnte man für die PNA-Nutzer nicht der Einfachheit halber eine der alten Versionen wieder ins Netz stellen? Auch wenn diese Version offiziell veraltet ist... ich bin megazufrieden damit und kann mir kaum vorstellen, was an den neueren Versionen jetzt noch besser ist :-) (konnte es ja leider auch nicht ausprobieren :-(
Aber eine Super-Werbung für den "großen" Totalcommander wäre das allemal.

Die Version, die bei mir läuft, nennt sich Totalcommander/CE V.1.11, C. Ghisler 2000-2003. Sie unterstützt schon die heute hier angebotenen Sprachfiles. Ich weiss nicht, wann sich dann etwas so grundlegendes geändert hat, dass er nicht mehr läuft. Aber die letzte lauffähige Version als PNA-Version einzustellen, wäre prima.

Gruß und danke für die hilfreiche Freeware!

User avatar
Snooze
Member
Member
Posts: 173
Joined: 2005-12-08, 16:48 UTC
Location: im Vest

Post by *Snooze » 2007-06-16, 15:47 UTC

habe mal gesucht und die V1.21 CE gefunden
(http://en.totalcmd.pl/download/app/old)

läuft aber auch nicht bei mir

albrecht33
Junior Member
Junior Member
Posts: 3
Joined: 2007-06-16, 14:21 UTC

Post by *albrecht33 » 2007-06-16, 17:18 UTC

Hallo,
habe es mal ausprobiert. Vers. 1.21 läuft bei mir auch nicht.

Post Reply