TC 9.12: Unstable list of content of Android device

Please report only one bug per message!

Moderators: white, sheep, Hacker, Stefan2

Post Reply
Slavic
Junior Member
Junior Member
Posts: 92
Joined: 2006-02-26, 15:41 UTC
Location: Moscow, Russia

TC 9.12: Unstable list of content of Android device

Post by *Slavic » 2018-04-13, 13:40 UTC

Total Commander is not always able to re-read the Android 8 device (Nexus 5X with Android 8.1 in my case) and show the content of internal storage. Often (but not always) the list is empty. Windows Explorer, on the other side, shows the content correctly.

How to reproduce:

1) Connect the device to PC. By default, it is connected for charging, so switch to "Transfer files" USB mode on the device (it was called MTP mode on previous Android versions).

2) On TC, select the device in the drop-down list, you should see "Internal shared storage", go into it and after a very small delay, like a half of second, you will see the directory list.

3) On device, change USB mode to "Charge this device", then re-read the content on TC (Ctrl+R or the toolbar icon). You will see the empty "Internal shared storage". (This is only a remembrance of previous path; if you go up, it disappears and you will see the empty device. But please don't change it for test.)

4) On device, switch back to "Transfer files". On TC, re-read the content again. In most cases, nothing appears. Sometimes it apparently works, but the content disappears after the second Ctrl+R. At this point, you may open Windows Explorer and navigate to the same device. Explorer shows the content well, while TC doesn't.

5) Try to switch the USB mode on the device back and forth several times, and use Ctrl+R (once or twice) every time after switch.

In many cases, re-reading the source on TC gives nothing, the list remains empty. Sometimes the content appears after noticeable delay or after other events like switching the tasks in Windows. So, this bug is not always reproducible, but occurs quite often. TC needs another event or "nudge" to re-read the source properly, other than Ctrl+R. Exiting TC and starting it again always shows the full content correctly.

It seems that the problem is in re-reading the empty cache in the situation when the full reading of device is obviously required. But I cannot exactly say whether this is TC bug or OS bug. It does not occur with Android 7.1 (tested on Lenovo tablet), so it may be a problem in interaction between Windows 7 and Android 8. Anyway I hope that there should be a way to force OS to refresh this cache, because Explorer can do it.
Desktop: Windows 7 x64, TC 9.20 b4. Mobile: LG Nexus 5X, Android 8.1, TC 2.90

User avatar
petermad
Power Member
Power Member
Posts: 8032
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad » 2018-04-13, 16:15 UTC

It woks fine here with Android 6.0 - so it is probably related to Android 8.1
License #524
Danish Total Commander Translator
TC 9.21a 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit and TC 2.91 on Android 6.0
Get Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36425
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-04-16, 15:38 UTC

This is actually a Windows 7 bug. Windows 7 seems to do some kind of caching of these virtual folders. The only way to fix it is to close and re-open Total Commander. On Windows 10, it works correctly - refreshing the lists shows/hides the files as expected.
Author of Total Commander
http://www.ghisler.com

Post Reply