[9.0a].cab files double drag and drop access violation crash

Please report only one bug per message!

Moderators: sheep, Hacker, Stefan2, white

Post Reply
gdpr deleted 2
Junior Member
Junior Member
Posts: 15
Joined: 2016-06-26, 13:39 UTC

[9.0a].cab files double drag and drop access violation crash

Post by *gdpr deleted 2 »

1. open .cab archive
2. Try to drag and drop file from this archive to the program, which can read this type of file(you cannot drag and drop files from archive so it is useless)
3. Try to drag and drop another any file from opened second tab of TC.
4. Program opens the file successfully
5. Go back to the TC.
6. Bam Bam
---------------------------
Total Commander 9.0a
---------------------------
Access violation.
Access violation
Windows 7 SP1 6.1 (Build 7601), base: 0400000

Please report this error to the Author, with a description
of what you were doing when this error occurred!

Stack trace (x64):413F35
414023 412B6E 40EDFC 86E522 500F60 5075E2 6EF093 6EF760
829990 81E363 4368D9 919381 85C23B 9235CB 76BA9BBD
Press Ctrl+C to copy this report!
Continue execution?
---------------------------
Yes No
---------------------------

gdpr deleted 2
Junior Member
Junior Member
Posts: 15
Joined: 2016-06-26, 13:39 UTC

Post by *gdpr deleted 2 »

.7z also affected

User avatar
sqa_wizard
Power Member
Power Member
Posts: 3558
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard »

Works fine here.

Tested with cab and 7z files and TC 9.0a 32 and 64-bit on Win7 x64
#5767 Personal license

gdpr deleted 2
Junior Member
Junior Member
Posts: 15
Joined: 2016-06-26, 13:39 UTC

Post by *gdpr deleted 2 »

sqa_wizard wrote:Works fine here.

Tested with cab and 7z files and TC 9.0a 32 and 64-bit on Win7 x64
You need to whitch to the TC from tray icon click.

gdpr deleted 2
Junior Member
Junior Member
Posts: 15
Joined: 2016-06-26, 13:39 UTC

Post by *gdpr deleted 2 »

I will make short demo video

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39807
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

This seems to be the same bug as described here:
https://ghisler.ch/board/viewtopic.php?t=48230

It should be fixed in TC 9.10 beta, please test it!
Author of Total Commander
http://www.ghisler.com

Post Reply